AVR483: DB101 Firmware - Getting Started

Features

Detailed walkthrough

Uses IAR Embedded Workbench

From new project to running code

Uses modules from Application Note AVR482

1 Introduction

Having all the software modules for DB101 provided by the Application Note
AVR®482 is great, but where do you start? What do you need to make your own
small application? Surely, you don’t want to start out with the demo application that
comes shipped with DB101 and break it down.

This application explains, step by step, how to create a new firmware project, add
the bare essentials for a basic graphics application, build it and run it on the
DB101.

Figure 1-1. The DB101 board.
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2 Your First DB101 Application

1. First, open IAR Embedded Workbench®. This walkthrough is based on IAR® EW
version 4.30A. The 4K code-size limited Kickstart version will do just fine as well.
Select “Create new project in current workspace” as shown in Figure 2-1.

Figure 2-1. “ Startup” Dialog Box.
x|

L4
ILDI Cregte new project in current workspace
Add existing project to current workspace

e |

2. The “Create New Project” dialog box will open. Select “Empty project”, as shown in
Figure 2-2, and click “OK”.

Figure 2-2. “New Project” Dialog Box.
x|

Tool chair: 4R =l

L

Description:

Creates an empty project.
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3. IAR will then ask you to select a location and filename for your new project, as
shown in Figure 2-3. Create a new folder somewhere and select a name for your
project. We've chosen to call it MyFirstApp. Click “Save” to move on.

Figure 2-3. “Save Project” Dialog Box.
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Safg in: | (2 do101wakkthrough
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File name: II'v1}'First.-'lpp|_‘_’/

Save as bype: IProje-:t Files " ewp)

4. You now have a new project in your editor. Before we add files to the project, we
need to configure the project options according to the AVR part we are using.
Select the “Options” item in the “Project” menu, as shown in Figure 2-4, to open

the Project Options dialog box.

Figure 2-4. The “Project” Menu.

Project Tools Window Help
Add Files. ..
Add Group...
Import File List. ..
Edit Configurations. ..

Remove

Create Mew Project...
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5. Select the “General Options” category, then the “Target” tab. Select the
ATmegal281 device in the drop down box shown in Figure 2-5.

Figure 2-5. “Target” Tab Options.
Options for node "MyFirstApp” ll

‘ General Options .
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Third-Party Driver ISmaII j
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Ok, | Cancel
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6. Now select the “System” tab in the same category, and make sure the “Enable bit
definitions in 1/0O-Include files” box is checked. Also make sure the “Data stack”
and “Return address stack” values are set as shown in Figure 2-6.

Figure 2-6. “System” Tab Options.

Options for node "MyFirstApp" 1[
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7. Select the “C/C++ Compiler” category, then the “Optimizations” tag. Make sure
medium size optimization is selected. The tab is shown in Figure 2-7.

Figure 2-7. “Optimizations” Tab Options.
Options for node "MyFirstApp” ll
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8. Now select the “Preprocessor” tab in the same category, and type “$PROJ_DIR$”
in the include directory path box as shown in Figure 2-8. This tells the compiler to
look inside the project directory for all the library and driver module files.

Figure 2-8. “Preprocessor” Tab Options.

Categony:

Eera Options ;

Custom Build

Build Actions

Linker

Debugger
CCR
ICE200
JTAGICE
JTAGICE mkIl
Simulator
Third-Party Driver

Languagel Code I Optimizations I Cutput | List

™ lgnore standard include directories: [STOOLKIT DIRSNING

STOOLKIT_DIRS\NC\CLIBY,

de directories: {one per ling)

SPROJ_DIRS

Preinclude file:

Defined symbals: {one per line) ™ Preprocessor output to file
;I I | Preserve commerts

™ Generate Hine directives

[

[
[~
|

(]4 I Cancel

AIMEL

——



ATMEL

9. Select the “Linker” category, then select the “Output” tab. Make sure the “ubrof 8
(forced)” format is selected, as shown in Figure 2-9. After that, click “OK” to apply
your changes.

Figure 2-9. “Output” Tab Options.
Options for node "MyFirstApp” ll
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10.This is a good time to save your entire workspace, with project settings and all.
Select the “Save All” item in the “File” menu, as shown in Figure 2-10. This will
save your project settings and then take you to the “Save Workspace” dialog box.

Figure 2-10. The “File” Menu.
[File Edit view Project Tools
MNew »
Open »
Close

Save Workspace
Closg Workspace

Save CTRL+ES
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11.1AR will then ask you to select a location and filename for your workspace, as
shown in Figure 2-11. We recommend that you locate the workspace file in the
same folder as the rest of your project files.

Figure 2-11. “Save Workspace” Dialog Box.

Save in: | 23 db101walkthrough ¥ « &= ek E-

IC ) settings

File name: @ j Save I
[~

Save as type: I".’-.u'orkspac:e Files (*eww) G

12.Now, we need to copy a few files from the DB101 firmware package to our new
project folder. Figure 2-12 shows the folder contents after copying the necessary
files. Not all files will be used directly in this demo, but there are dependencies
between some modules, so all files shown need to be there.

Figure 2-12. Project Folder Contents
[Jicd i h]

MyFirstApp.ewd
MyFirstApp.ewp
@ MyFirstApp.eww

s6b1713 driver.c
s6b1713_driver.h
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13.Then we need to add the source files to our project. Select the “Add Files” item in
the “Project” menu, as shown in Figure 2-13.

Figure 2-13. The “Project” Menu.

Import File List. ..
Edit Configurations. ..

Remove

Create Mew Proiect.

14.In the “Add Files” dialog box, select all source files, that is every file with the “.c”

extension, as shown in Figure 2-14. Then click “Open” to add the files to your
project.

Figure 2-14. “Add Files” Dialog Box.

Look in: I&)db1:1-,\-alldhrough j - =% Eg-

IZ] timing_lib.h

File name: I"timing_lib.c" "backlight_driver.c" "fifo_lib.c" "gj Open I
Files of type: ISource Files ".c;"cpp;” e h;” hpp ;'.s';'.msa;'j Cancel |
F

15.With all library and driver modules added to our project, we need to create a main
source file for our demo application. Select the “New -> File” item in the “File”
menu as shown in Figure 2-15. IAR will create a new file named “Untitledl” or
something similar, and open the file in the editor.

Figure 2-15. The “File” Menu.

File Edit ¥iew Project Tools Winde

L4 | File CTRL+M
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16.Find the “main.c” file in the code package that comes with this document and
copy the contents into the new file in the editor. The editor should new look as
shown in Figure 2-16.

Figure 2-16. File Contents

lrst spplication for DB1O01.
e "led 1ib.h"

ngfx 1ib.n"

"joystick driver.h"

"rimi lib.h"

<iocavr.h>
<inavr.h>

by Jjovstick driver.

139 ! Prototype for our first demo function.
20 v lipnes demo( wvoid );

21

22 /! Application starts hers.

23void main( wvoid )

24 {

17.Now you should save the new file. Select the “Save” item in the “File” menu as
shown in Figure 2-17.

Figure 2-17. The “File” Menu.
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18.Since this is the first time you save the new file, IAR will ask you for a file name.
We chose to call it “main.c” as shown in Figure 2-18.

Figure 2-18. "Save File” Dialog Box.
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19.0ur new source file needs to be added to our project. An easy way to do this,
when there’s only one new file to add, is to right-click on the project name in the

“Workspace” window, select “Add”, and then “Add “main.c™ as shown in Figure 2-
19.

Figure 2-19. The Right-click Project Menu
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20.Now is a good time to save project and workspace again, as shown in Figure 2-20.
Since you've already given a name to project, workspace and source files, IAR will
not ask you for a name again.

Figure 2-20. The “File” Menu.
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21.With all files ready, it's time to compile and build our application. Select the “Make”
item in the “Project” menu as shown in Figure 2-21.

Figure 2-21. The “Project” Menu.

Project Tools Window Help
Add Files. ..
Add Group...
Import File List. ..
Edit Configurations. ..
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22.During the build process the Message window will show the progress. When the
build is complete, the Message window should report no errors and no warnings,
as shown in Figure 2-22. It not, locate the errors or warnings and resolve.

Figure 2-22. The “Message” Window.

x

| hessages

3024 bytes of CODE memaoary [+ 140 range fill)
128 bytes of DATA memaory (+ 31 absolute )

Errars: none
Warnings: none

Total number of errors: 0
Total number of warmings: 0
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23.The demo application is not built en ready for running on the DB101. Open AVR
Studio® and click “Open” in the “Welcome” dialog box, as shown in Figure 2-23.

Figure 2-23. “Welcome” Dialog Box.

Welcome to AVR Studio 4
é MNew Project ‘

'b\ 3 Fiecent projects | M odified
(] =
—
oy

24.1n the “Open Project File or Object File” dialog box, locate and select the debug
file for your demo application. It will be located under the “Debug\Exe” folder in
your project folder. The filename will be the same as your project file, as shown in
Figure 2-24. Now click “Open”.

Figure 2-24. “Open Project File or Object File” Dialog Box.
Open Project File or Object File il
Loak in: IE}E:(B j e cF B3~

File name: II'vh'FirstApp.dbg j Open I
Files of type: [Project Fizs, Object Files (aps,"hex 49025 7 | Cancel |
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25.AVR Studio will ask you for a filename for the AVR Studio project. We recommend
that you just accept the suggested file and location, as shown in Figure 2-25.

Figure 2-25. “Save AVR Studio Project File” Dialog Box.
Save in: | 23 db101walkthrough v « &k E-

|2 Debug
ICo) settings

File name: I yFirst App_dbag aps j Save

Save as type: I_-’l_"u"R Studio Project Files (".aps) j ncel |

AVR Studio will create a project for debugging this object file. To ensure optimal debugging, AVR Studio’s project
file should be located at the root of the orginal source file project. I the oniginal source is not available, you can
save the project fils at the same place as the object file

26.Now, you need to select which debug platform and device you are using. Select
“JTAGICE mkKll” and “ATmegal281” as shown in Figure 2-26. Make sure your

JTAGICE mKll is connected to your computer and to the DB101 board, and the
both are powered, then click “Load".

Figure 2-26. “Debug and Platform Selection” Dialog Box.

Welcome to AVR Studio 4
— Select debug platiorm and device

Debug platform: Device:

&R Dragon ATI0PwWM2B -]
AWE Simulator AT 0P 3 _I
Fpzlic CoSimulator ATI0P 3B

FPSLIC JTAG ICE ATH0USE1286

ICE200 ATH0USET287

ICE40 ATI0USB1EZ

ICERD ATS0USBR4E

Al ICE ATH0USER4T
JTAGICE mkll ATmegal 28
Part: I»’-‘«uto VI [~ Dpen platform optionz

Yer 413.532

<< Back | ezt 22 I Load LCancel Help
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27.AVR Studio will now connect to your JTAGICE mkll and program your application
into the ATmegal281 on the DB101 board. After a short while, the debug session
starts, and AVR Studio indicates that code execution is stopped at the first line of
the main() function, as shown in Figure 2-27.

Figure 2-27. Debug Session Waiting to Run

_ioix]
vold main{ woid )
{ o &
#% ——— Initialize required modules ——— %~

<« LCD graphics.
=l LeD Initi);
<« Backlight driwvers.
BACKLIGHT Init():
s« Timing library. needed for e.g. joystick dr
TIHING Init():
s Real-time clock. providing a useful timehas
RTC _Initi):
s Joystick driver. 100 ticks press—and-hold d
s« and 50 ticks double-click delay.
JOYSTICK Indit( 100, 50 3;

S Connect timing library to Eeal-time clock &
RTC_SetTickHandler({ TIMING TickHandler }:

S0 Setup a8 regular timing event to handle joys
TIMING_AddRepCallbackEvent( TIHING_INFINITE_RE

JOYSTICK PollingHas+
1] | 4

28.Now, everything you have to do is select the “Run” item in the “Debug” menu, and
then use the joystick to change the line on the LCD.

Figure 2-28. The “Debug” Menu.

3 | Debug | Window Help
P | StartDeb g Cirl+skift+Alt+5 | @
R = ging Ctrl+5kift+F75 {5
EE ) F5 |pm
T T Ctrl+F5 %
Ll Reset Skift+F5 p
¥E StepInto Fi1 |
[L.= sten Over Fo | L

29.1f you want to, you can break code execution, go back to IAR, change the code, go
back to AVR Studio, accept reload, and then run the code again. Enjoy!
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