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1. Hardware Setup 
 

1. Please follow the hardware setup instructions below to use BASCOM51 with BiPOM's MINI-MAX/51 boards. 
For using BASCOM51 with other 8051 hardware, please follow the hardware setup and download instructions 
that apply to your hardware. 

2. Place the MINI-MAX/51-C2 Microcontroller board on a clean, non-conductive surface. 

3. Connect the provided 6VDC power supply plug to the power jack on the MINI-MAX/51-C2. Do not connect the 
power supply to the outlet yet.  

CAUTION: Do not use a power supply other than one that is supplied or approved by BiPOM Electronics. Use of 
another power supply voids the warranty and may permanently DAMAGE the board or the computer to which the 
board is connected !!! 

4. Connect the MINI-MAX/51-C2 to an available serial port on the PC using the supplied serial cable as shown 
below. 

5. Connect the 6VDC power supply to a suitable wall outlet. 

 

 

 

 

 

MINI-MAX/51-C2 Board 

RS232 Serial Cable  

Power Cable  

To outlet  

PC  
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2. BASCOM51 Installation Instructions 
 
2.1 Micro-IDE Installation 
 
Download BASCOM51 from: 

http://www.bipom.com/bascom51_down.php 

 

Click on bascom51_devsys.exe link. Select Save File. Downloading will start. 

 

http://www.bipom.com/bascom51_down.php
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When the download completes, double click on the file bascom51_devsys.exe to start installation:  

 

 
 

Click Next. 
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Agree to the license agreement by clicking Yes. 
 

 
 

 
If you have a serial number from BiPOM, enter your serial number in the Serial field. If it says DEMO in this field, 
delete DEMO and enter your serial number. 
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Install to default location: c:\bipom\devtools 

Click Next. 

 

Use default Program Folder Micro-IDE. Click Next. 
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Installation will start. 

 

 

Click Finish. This will start Micro-IDE. 

When Micro-IDE starts, you will be asked to open or create a project: 



12 

 

 

Click Cancel. 

 

2.2 Registering Layered Products 

If you have additional serial numbers to specify ( for example, for layered products such as 8051 Simulator and 
8051 Debugger ), you can enter these one by one using Help->Add Serial Number: 

 

Type your serial on the field shown with 0’s; there is no need to type dashes. Click OK when finished. 

Do this for each additional serial number that you have. 

Exit Micro-IDE using File->Exit or by closing the Micro-IDE window. 
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2.3 Activating BASCOM51 Compiler License 

Copy BASCOM51 license files to activate the BASCOM51 license. This step is important because BASCOM51 
will run in demo mode if it does not detect the two license files that it needs. 

To do this, open the original order email that was sent to you from info@bipom.com: 

 

Open the zip attachment ( bascom51.zip ): 

 

 

mailto:info@bipom.com
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Copy the 2 license DLL files from bascom51.zip to BASCOM51 folder as shown below: 
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Check to see if the license files BASC5132.DLL and BSC5132L.DLL are in the BASCOM51 folder: 

 

 

Your BASCOM51 license should not be activated. Start Micro-IDE and use BASCOM51 without any restrictions. 
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You can check the status of licenses using Help->About in Micro-IDE: 

 

IMPORTANT: BASCOM51 status is Unknown because Micro-IDE does not keep track of license status of layered 
compilers. This is OK and it means that BASCOM51 may or may not have a license. 
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3. Downloading an Example Program 

3.1 Opening the Example Project 
 
To open and run an existing BASIC program example, please follows these instructions: 
 
Start Micro-IDE from Start à Programs à Micro-IDE. 
 
When Micro-IDE starts, the Project Selection window appears: 
 

 
 

Click Open existing project and then OK. 
 
BASCOM51 Development System is distributed with several examples. Example projects are located under the 
Examples folder under C:\bipom\devtools\Bascom51\Examples\. 
 
Open the project file C:\bipom\devtools\Bascom51\Examples\hello\hello.prj . When the project opens, you will 
see the source of the 'hello' program. 
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3.2 Building the Project 
 
Click Toggle Output icon button. This will display the Output pane.  
 
NOTE: If the Output pane was already open from before, do not click Toggle Output button as this will hide the 
Output pane.  
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Output Pane 

Toggle Output 
button 
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Press the  Build All icon button. This will generate the output file hello.hex under following folder: 
 
C:\bipom\devtools\Bascom51\Examples\hello\ 
 

 

The output messages above indicate that the program compiled successfully. If there are errors in the program, 
you will see the corresponding error messages in the Output Pane. 

 

 

 

 

 

 

 

 

 

Build All button 

Building output 
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3.3 Downloading the Program  

To download the output hello.hex file to the target board, press the Download icon button on the toolbar. If the 
board is powered and connected properly to the PC, a progress dialog will appear: 
 

 
 

 
 
 

The progress dialog will disappear after a successful download. Details of the download are shown on the Output 
pane: 
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3.4 Running the Program 

When the download completes, the progress indicator disappears. This means that the board has received the 
program successfully. After the program has been successfully downloaded, the program can be started using the 
Mode button on the main Toolbar: 

 

Mode button puts the board either into Run or Program mode. In Run mode, the microcontroller is executing the 
program in its memory. In Program mode, the microcontroller is in Reset state so no programs are running. In 
Program mode, microcontroller’s flash memory can be changed and a new program can be downloaded. 

Before running the program, open the Terminal window first to see the output of the example program. Following 
are the buttons on Terminal Toolbar: 

 

 

Connect Terminal - When you click this button, the terminal opens and connects to the selected COM port. 
When the target board sends data to its serial port, the messages will appear in Terminal window. 

Any characters typed in the Terminal window will be sent to the board through the COM port to which Terminal is 
connected. 

Disconnect Terminal - Disconnects from and closes the COM port. 

Open Terminal – Displays or hides the Terminal. 
 
Clear Terminal – Erases the contents of the Terminal window. 
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To specify the options for Terminal, select Tools à Options in main menu to open the Options dialog. Select 
Terminal tab: 

 

Select the correct PC COM port that you have connected the board. Other settings should be set as below: 

Baudrate: 19200 

Parity: None 

Data Bits: 8 

Stop bits: 1 

Echo: On – Micro IDE echoes to ( prints ) in terminal window what the user types; Off - Micro IDE does not print 
in terminal window what the user types. 

Click the OK button to save the settings and close the Options dialog. 
 

The Mode button is Red in Program mode and Green in Run mode. Following a download, the Mode button will 
be Red. Click the Mode button to change the mode to Run mode. The program that was downloaded last starts 
executing. 

You should now see the message “hello world” being displayed on the Terminal window. 

Congratulations!!! You have built and executed your first program on the BASCOM51. 

For more help, please read Help for Micro-IDE (BASCOM-51) under Help menu of Micro-IDE.  

A full set of BASCOM commands is under BASIC Language Reference under Help menu of Micro-IDE.  
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3.5 What to do if download fails ? 

The MINI-MAX/51-C Downloader has been available for several years now and is a highly reliable downloader.  
 
You should only pay attention to few details to make sure that the download works: 
 
- Make sure that the board is powered. 
 
- Make sure that you are using the NULL modem cross cable ( Laplink cable ) that came with the board. Other 
NULL modem cables may not work. Straight through cables will NOT work. 
 
- Make sure that you are using the correct serial (COM) port. Some PC's have more than one serial port. Check  
Tools->Options->Loader in Micro-IDE for the correct COM port. Baud rate, parity, data bits, stop bits, etc. do 
not make a difference for the MINI-MAX/51-C Loader. All these are automatically detected by the loader. 
Similarly, the microcontroller type on the board is detected automatically.  
 

 
 
  
- Make sure that you use the latest software from our website. Older versions of the software may not support 
newer processors such as the AT89C51ED2. Both the 8051 Development System and BASCOM51 include the 
latest MINI-MAX/51-C Loader. 
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4. Creating Your Own BASIC Program  

4.1 Creating a New Project 

To create your own project, select Project menu and select New Project. This will display the New Project 
dialog. 

 
Enter the name of the new project and its location ( this example uses example as the project name and 
C:\bipom\devtools\BASCOM51\Examples\example\ as the project location ). Select BASCOM 8051 as the 
Toolkit.  

Click OK. You will be prompted to create directory for the project. Click Yes. 

 

After this you will be prompted to create new source file. Also click Yes. 

 

The new project with the name of example will be created under: 

C:\bipom\devtools\BASCOM51\Examples\example\   

The  project will now have an example.bas program file that was automatically created by Micro-IDE. This is a 
blank template file of a BASCOM51 BASIC program. Comments contain configuration commands for LCD, I2C 
and Serial port. In this example we will use only Serial port so uncomment the lines that have Serial port 
configuration.  
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The resulting code is shown below: 
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4.2 Adding program lines 

Now add aliases for ports on the MINI-MAX/51-C2 board. These will be used to control LED’s on TB-1 Peripheral 
Board if this board is connected. Otherwise program will simply change the logic levels on the port pins. 

NOTE: More information about TB-1 Peripheral board is available on BiPOM web site: 

TB-1 Peripheral Board - http://www.bipom.com/products/us/213.html 

MINI-MAX/51-C2 Board  - http://www.bipom.com/products/us/318646.html 

Add the following lines of code below all text in examples.bas: 

RED  Alias P1.3  'define port pin of Red LED   
YELLOW Alias P1.1  'define port pin of Yellow LED  
GREEN  Alias P1.0  'define port pin of Green LED  
 
These lines of BASIC code creates aliases for three pins on PORT 1. This way, we can use RED instead of P1.3 
to make the program more readable. 

Below this, add code to print a greeting message as soon the program is started. Program will print message to 
the Serial port. 

Print  
Print "Checking LEDs..." 
 
As soon the program starts running, Checking LEDs... message will be displayed in Micro-IDE Terminal 
window. 
 
The following code adds an infinite loop that turns on/off all three LED’s on TB-1 board one by one with a one 
second delay in between: 

Do 
 Print    "RED" 
 Reset  RED 
 WaitMs 1000 
 Set  RED 
 
 Print    "YELLOW" 
 Reset  YELLOW 
 WaitMs 1000 
 Set  YELLOW 
 
 Print    "GREEN" 
 Reset  GREEN 
 WaitMs 1000 
 Set  GREEN 
Loop   
 

http://www.bipom.com/products/us/213.html
http://www.bipom.com/products/us/318646.html
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Do Loop  - This statement makes a forever loop  
Print  - Sends specified string to Serial port 
Reset  - Resets a bit of a microcontroller output port 
Set  - Sets a bit of a microcontroller output port 
WaitMs - Suspends program execution for a given time in milliseconds 
 
The End statement at the very end of program code tells BASCOM51 Compiler that this is the end of program. 
 
NOTE: More information about BASCOM 8051 Language is on BiPOM web site: 
 
http://www.bipom.com/bashelp/bascom51.htm 
 
After all these changes, the program should look like the following: 
 
'LCD CONFIGURATION 
'CONFIG  LCDPIN=PIN,DB4=P0.4,DB5=P0.5,DB6=P0.6,DB7=P0.7,E=P0.2,RS=P0.0 
 
'SERIAL PORT CONFIGURATION 
$BAUD = 19200  'set 19200 baud rate for 
$CRYSTAL = 22118400 '22.1184 MHz crystal 
 
'I2C BUS CONFIGURATION 
'CONFIG SCL = P1.6 'P1.6 is the SCL line 
'CONFIG SDA = P1.7 'P1.7 is the SDA line 
'CONFIG I2CDELAY = 25 
 
RED  Alias P1.3  'define port pin of Red LED   
YELLOW Alias P1.1  'define port pin of Yellow LED  
GREEN  Alias P1.0  'define port pin of Green LED 
 
Print  
Print "Checking LEDs..." 
 
Do 
 Print    "RED" 
 Reset  RED 
 WaitMs 1000 
 Set  RED 
 
 Print    "YELLOW" 
 Reset  YELLOW 
 WaitMs 1000 
 Set  YELLOW 
 
 Print    "GREEN" 
 Reset  GREEN 
 WaitMs 1000 
 Set  GREEN 
Loop   
End 

http://www.bipom.com/bashelp/bascom51.htm
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4.3 Building and Running a Program 
 
Press Build All icon button. This will generate the output file example.hex in project folder. 
If program is built successfully, the following messages will be displayed in Output pane: 
 

 
 

Download the program to the board by clicking the Download button on the main toolbar. If the board is powered 
and connected properly to the PC COM port, a progress dialog will appear. 

When download completes, run the program by clicking the Mode button on the main toolbar. The Mode button 
should be green now. You will see that the LED’s on TB-1 turn on and off if TB-1 board is connected. 

Congratulations!!! You have built and executed your first BASCOM 8051 program on the MINI-MAX/51-C2. 

 
 
 
 


